COSTO DE ENTRADA POR GRUPOS - PSeInt.Site

 

 

 

DESARROLLAMOS TUS ALGORITMOS (+51) 988411115

17. En una Feria de Libros, los precios de las entradas tienen descuentos por la cantidad de personas que ingresa en grupos. Los menores de 4 personas tienen descuento del 20% el precio de entrada, los grupos de 4 personas y menores de 10 personas tiene descuento del 35% del precio de entrada y de 10 personas a más tienen descuento del 50%. Calcular cuánto pagará cada persona por el precio de entrada y el monto total a pagar por el grupo.

A. Ingreso de datos.

 

B. Precio a pagar por una entrada.

C. Monto total por el grupo.

¿EN QUE PROGRAMA QUIERES VER EL CÓDIGO? :

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web.

ANÁLISIS :

Para este ejercicio se pide la cantidad de personas y el costo por entrada, para tener un precio total bruto; luego obtener el descuento en base a la cantidad de personas y las distintas condiciones. Una vez obtenido el descuento este se aplica al precio bruto para obtener el precio total.

Para obtener el precio por persona se divide el precio total entre la cantidad de personas.

ENTRADA : cantidad de personas (personas), precio de entrada(entradas)

SALIDA : precio de cada entrada (precio) y costo total (total)

PROCESO : Se realizan las validaciones para obtener el descuento por la cantidad de personas, y luego mostrar el costo por persona y el monto total.

PSeInt - FLEXIBLE DESCARGA CÓDIGO

Proceso www_pseint_site Escribir Sin Saltar "Cantidad de personas : " Leer personas Escribir Sin Saltar "Precio de entrada : " Leer entradas Si (personas >= 10 ) Entonces desc = 0.50 SiNo Si (personas >= 4 y personas < 10) Entonces desc = 0.35 SiNo Si (personas < 4) Entonces desc = 0.20 FinSi FinSi FinSi precio = personas * entradas total = precio - (precio * desc) Escribir "" Escribir "ENTRADA POR PERSONA : ", total/personas Escribir "MONTO TOTAL : ", total FinProceso

PSeInt - ESTRICTO DESCARGA CÓDIGO

Proceso www_pseint_site Definir personas Como Entero; Definir precio, entradas, desc, total como Real; desc

COSTO DE ENTRADA POR GRUPOS - PSeInt.Site

COSTO DE ENTRADA POR GRUPOS - PSeInt.Site

B. Precio a pagar por una entrada. A. Ingreso de datos. A. Ingreso de datos. DESARROLLAMOS TUS ALGORITMOS (+51) 988411115 DESARROLLAMOS TUS ALGORITMOS (+

programar

es

https://aprendeprogramando.es/static/images/programar-costo-de-entrada-por-grupos-pseint-658-0.jpg

2024-05-19

 

COSTO DE ENTRADA POR GRUPOS - PSeInt.Site
COSTO DE ENTRADA POR GRUPOS - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /condicional/costo-de-entrada-a-la-libreria/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente