Ingrese número natural de dos cífras - PSeInt.Site

 

 

 

DESARROLLAMOS TUS ALGORITMOS (+51) 988411115

 

13. Elaborar un pseudocódigo donde se ingrese por teclado un número natural de hasta 2 cifras, si tiene una cifra muestre lo mínimo que le falta para ser un número de 2 cifras; de lo contrario muestre lo mínimo que le falta para ser un número de 3 cifras. Considerar que el usuario ingresa números de hasta dos cifras.

¿EN QUE PROGRAMA QUIERES VER EL CÓDIGO? :

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web.

ANÁLISIS :

Para resolver este ejercicio tenemos que hacer una condición anidada, se debe preguntar que el número ingresado no sea mayor de tres cifras y consultar si es de una cifra, si se da el caso completamos el valor restando diez menos el valor ingresado para que sea de dos cifras o lo requerido para completar que sea de tres cifras.

PSeInt - FLEXIBLE DESCARGA CÓDIGO

Algoritmo num_cifras Escribir "NUMERO: " Leer num Si num > 99 Entonces Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS" SiNo Si num < 10 Entonces Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS" SiNo Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS" FinSi FinSiFinAlgoritmo

PSeInt - ESTRICTO DESCARGA CÓDIGO

Algoritmo num_cifras Definir num, cifras como Entero; Escribir "NUMERO: "; Leer num; Si num > 99 Entonces Escribir "ERROR... EL NUMERO SUPERA LAS 2 CIFRAS"; SiNo Si num < 10 Entonces Escribir "LE FALTA ", 10-num ," PARA 2 CIFRAS"; SiNo Escribir "LE FALTA ", 100-num ," PARA 3 CIFRAS"; FinSi FinSi FinAlgoritmo

Lenguaje CDESCARGA CÓDIGO

#includeint main() { int num, cifras; printf("13. MUESTRE LO FALTANTE PARA 2 o 3 CIFRAS.\n\n"); printf("Ingrese Numero : "); scanf("%i",&num); if (num > 99) { printf("\nERROR... EL NUMERO SUPERA LAS 2 CIFRAS"); }else{ if (num < 10) { printf("\nLE FALTA %d PARA 2 CIFRAS", 10-num); }else{ printf("\nLE FALTA %d PARA 3 CIFRAS", 100-num); } } return 0;}

C++DESCARGA CÓDIGO

#includeusing namespace std;int main() { int num, cifras; cout num; cout 99) { cout

Ingrese número natural de dos cífras - PSeInt.Site

Ingrese número natural de dos cífras - PSeInt.Site

ANÁLISIS : PSeInt - FLEXIBLE DESCARGA CÓDIGO PSeInt - ESTRICTO DESCARGA CÓDIGO Lenguaje CDESCARGA CÓDIGO C++DESCARGA CÓDIGO

programar

es

https://aprendeprogramando.es/static/images/programar-ingrese-numero-natural-de-dos-cifras-pseint-660-0.jpg

2024-05-15

 

Ingrese número natural de dos cífras - PSeInt.Site
Ingrese número natural de dos cífras - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /condicional/ingrese-numero-de-2-cifras-para-completar-tres/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente

 

 

Update cookies preferences