Ingrese 3 números y muestre el número intermedio - PSeInt.Site

 

 

 

 

DESARROLLAMOS TUS ALGORITMOS (+51) 988411115

Mostrar el número intermedio

08. Elaborar un programa que ingrese 3 números y muestre el número intermedio.

¿EN QUE PROGRAMA QUIERES VER EL CÓDIGO? :

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web.

  Lenguaje C

  C++

  C#

  Python

  Java NetBeans

ANÁLISIS :

Hay muchas formas de desarrollar este ejercicio, en este caso lo que haremos será comparar cada número hasta obtener el intermedio:

Aplicaremos la lógica del primer diagrama de flujo:

Tomamos como referencia: N1 = 5, N2 = 3, N3=9; a simple vista el número intermedio sería 5.

Paso 1: Si ¿N1(5) es mayor que N2(3)?; “entonces MEDIO = N1 (5) y XTEM = N2(3)”; No aplicamos el caso contrario porque no se cumple. Euromillones con ChatGPT IA

Paso 2: Si ¿MEDIO(5) es mayor que N3(9)?, “NO SE CUMPLE”.

Paso 3: Si ¿MEDIO(5) es mayor que XTEM(2)?, “NO SE CUMPLE”.

Paso 4: Por lo tanto mostramos por pantalla el Número intermedio: MEDIO(5).

La base está en la primera consulta, dónde se toma el valor intermedio como referencia, para final mente compararlo con el último valor.

DIAGRAMA DE FLUJO - OPCIÓN 01:

DIAGRAMA DE FLUJO - OPCIÓN 02:

PSeInt - FLEXIBLE DESCARGA CÓDIGO

Algoritmo Condicional08 Escribir "Ingrese Número 01 : " Leer N1 Escribir "Ingrese Número 02 : " Leer N2 Escribir "Ingrese Número 03 : " Leer N3 Si N1 > N2 Entonces MEDIO = N1 XTEM = N2 SiNo MEDIO = N2 XTEM = N1 Fin Si Si MEDIO > N3 Entonces MEDIO = N3 Fin Si Si MEDIO < XTEM Entonces MEDIO = XTEM Fin Si Escribir "El número Medio es : ", MEDIOFinAlgoritmo

PSeInt - ESTRICTO DESCARGA CÓDIGO

Algoritmo Condicional08 Definir N1, N2, N3, MEDIO, XTEM como Entero; Escribir "Ingrese Número 01 : "; Leer N1; Escribir "Ingrese Número 02 : "; Leer N2; Escribir "Ingrese Número 03 : "; Leer N3; Si N1 > N2 Entonces MEDIO n3; if (n1>n2) { medio = n1; xtem = n2; } else { medio = n2; xtem = n1; } if (medio > n3) { medio = n3; } if (medio < xtem) { medio = xtem; } cout N3){ MEDIO = N3; } if(MEDIO < XTEM){ MEDIO = XTEM; } System.out.println("EL NÚMERO MEDIO ES : " + MEDIO); }}

Java Script DESCARGA CÓDIGO

Ejercicio Condicional en JS - 08 xn2){ medio = xn1; xtem = xn2; }else{ medio = xn2; xtem = xn1; } if(medio > xn3){ medio = xn3; } if(medio < xtem){ medio = xtem; } document.getElementById('result').value=medio;}]]> INGRESE NUMERO 01 :

INGRESE NUMERO 02 :

INGRESE NUMERO 03 :

EL NUMERO MEDIO ES:

Visual Basic .Net - Consola DESCARGA CÓDIGO

Imports System.ConsoleModule Module8 Dim N1, N2, N3, Medio, XTem As Integer Sub Main() Write("Igrese Número 1 : ") N1 = ReadLine() Write("Igrese Número 2 : ") N2 = ReadLine() Write("Igrese Número 3 : ") N3 = ReadLine() If (N1 > N2) Then Medio = N1 XTem = N2 Else Medio = N2 XTem = N1 End If If (Medio > N3) Then Medio = N3 End If If (Medio < XTem) Then Medio = XTem End If WriteLine("El Número Medio es : " & Medio) ReadLine() End SubEnd Module

Ingrese 3 números y muestre el número intermedio - PSeInt.Site

Ingrese 3 números y muestre el número intermedio - PSeInt.Site

ANÁLISIS : DIAGRAMA DE FLUJO - OPCIÓN 01:DIAGRAMA DE FLUJO - OPCIÓN 02: PSeInt - FLEXIBLE DESCARGA CÓDIGO PSeInt - ESTRICTO DESCARGA CÓDIGO Java Script DE

programar

es

https://aprendeprogramando.es/static/images/programar-ingrese-3-numeros-y-muestre-el-numero-intermedio-pseint-661-0.jpg

2024-05-19

 

Ingrese 3 números y muestre el número intermedio - PSeInt.Site
Ingrese 3 números y muestre el número intermedio - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /condicional/mostrar-el-numero-intermedio/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente