DIAGONAL PRINCIPAL - PSeInt.Site

 

 

 

11. Desarrolle un algoritmo con arreglo bidimensionales para calcular lo siguiente:

1. Suma de las diagonales principales.

 

2. Promedio de la fila y columna escogida por el usuario final.

3. Determine el número mayor y menor de la matriz.

4. ¿Cuántas veces se repite un número dado?

PSeInt - FLEXIBLEDESCARGA CÓDIGO

Proceso www_PSeInt_Site Definir f, c, dato, opc, suma, s, may, men, repite como Entero; Dimension suma[4,4]; Para f = 1 hasta 4 Con paso 1 Hacer Para c = 1 hasta 4 Con paso 1 Hacer suma[f,c] = azar(9); FinPara FinPara Escribir "DATOS DE LA MATRIZ"; Para f = 1 hasta 4 Con paso 1 Hacer Para c = 1 hasta 4 Con paso 1 Hacer Escribir Sin Saltar suma[f,c], " "; FinPara Escribir " "; FinPara Escribir " "; Escribir "------------- TRABAJO CON MATRIZ ----------------"; Escribir "1. Suma de las diagonales principales."; Escribir "2. Promedio de la fila y columna escogida por el usuario final."; Escribir "3. Daterminar el número mayor y menor de la matriz."; Escribir "4. ¿Cuántas veces se repite un número dado?"; Escribir Sin Saltar "Opcion : "; Leer opc; Escribir " "; Segun (opc) Hacer 1 : s = 0; Para f = 1 hasta 4 Con paso 1 Hacer s = s + suma[f,f]; FinPara Escribir "SUMA DIAGONAL 1 :",s; s = 0; Para f = 1 hasta 4 Con paso 1 Hacer s = s + suma[f,5-f]; FinPara Escribir "SUMA DIAGONAL 2 :",s;
2 : Escribir Sin Saltar "Eliga una fila o columna : [1 - 4]"; Leer dato; Si (dato > 0 y dato suma[f,c]) Entonces men = suma[f,c]; FinSi FinPara FinPara Escribir "MAYOR ES :", may; Escribir "MENOR ES :", men; 4 : Escribir Sin Saltar "Ingrese número : "; leer dato; Para f = 1 hasta 4 Con paso 1 Hacer Para c = 1 hasta 4 Con paso 1 Hacer Si (dato == suma[f,c]) Entonces repite = repite + 1; FinSi FinPara FinPara Escribir "SE REPITE : ", repite, " VECES"; FinSegun FinProceso

PSeInt - ESTRICTODESCARGA CÓDIGO

Proceso www_PSeInt_Site Definir f, c, dato, opc, suma, s, may, men, repite como Entero; Dimension suma[4,4]; s

DIAGONAL PRINCIPAL - PSeInt.Site

DIAGONAL PRINCIPAL - PSeInt.Site

2. Promedio de la fila y columna escogida por el usuario final. 1. Suma de las diagonales principales. 1. Suma de las diagonales principales.

programar

es

https://aprendeprogramando.es/static/images/programar-diagonal-principal-pseint-687-0.jpg

2024-05-19

 

DIAGONAL PRINCIPAL - PSeInt.Site
DIAGONAL PRINCIPAL - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /matrices/suma-de-las-diagonales-principales/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente

 

 

Update cookies preferences