Ingrese un número y muestra en letras - PSeInt.Site

 

 

 

DESARROLLAMOS TUS ALGORITMOS (+51) 988411115

Mostrar número en letras.

08. Ingresar un número entero de dos cifras y mostrar su valor en letras.

¿EN QUE PROGRAMA QUIERES VER EL CÓDIGO? :

 

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web.

  Lenguaje C

  C++

  C#

  Python

  Java NetBeans

Diagrama de flujo(DFD) - Ingresa un número y muestralo en letras:

PSeInt - FLEXIBLE DESCARGA CÓDIGO

Algoritmo Seleccion08 Escribir "Ingrese Número de Hasta 2 Cifras : " Leer Num Si Num > 0 Y Num < 100 Entonces Si Num > 10 Y Num < 16 Entonces Segun Num Hacer 11: Escribir "ONCE" 12: Escribir "DOCE" 13: Escribir "TRECE" 14: Escribir "CATORCE" 15: Escribir "QUINCE" Fin Segun SiNo DEC = (Num - (Num MOD 10))/10 UNI = Num MOD 10 Segun DEC Hacer 1: DECENA = "DIEZ" 2: DECENA = "VEINTE" 3: DECENA = "TREINTA" 4: DECENA = "CUARENTA" 5: DECENA = "CINCUENTA" 6: DECENA = "SESENTA" 7: DECENA = "SETENTA" 8: DECENA = "OCHENTA" 9: DECENA = "NOVENTA" Fin Segun Si UNI 0 Entonces Segun UNI Hacer 1: UNIDAD = "UNO" 2: UNIDAD = "DOS" 3: UNIDAD = "TRES" 4: UNIDAD = "CUATRO" 5: UNIDAD = "CINCO" 6: UNIDAD = "SEIS" 7: UNIDAD = "SIETE" 8: UNIDAD = "OCHO" 9: UNIDAD = "NUEVE" Fin Segun Si DEC = 1 Entonces DECENA = "DIECI" FinSi Si DEC = 2 Entonces DECENA = "VENTI" FinSi Si DEC > 2 Y DEC < 10 Entonces Escribir DECENA "Y" UNIDAD SiNo Escribir DECENA "" UNIDAD FinSi SiNo Escribir DECENA Fin Si Fin Si SiNo Escribir "NÚMERO INCORRECTO !!!..." Fin SiFinAlgoritmo

PSeInt - ESTRICTO DESCARGA CÓDIGO

Algoritmo Seleccion08 Definir Num, DEC, UNI como Entero; Definir DECENA, UNIDAD como Caracter; Escribir "Ingrese Número de Hasta 2 Cifras : "; Leer Num; Si Num > 0 Y Num < 100 Entonces Si Num > 10 Y Num < 16 Entonces Segun Num Hacer 11: Escribir "ONCE"; 12: Escribir "DOCE"; 13: Escribir "TRECE"; 14: Escribir "CATORCE"; 15: Escribir "QUINCE"; FinSegun SiNo DEC 0) And (Num < 100)) Then If ((Num > 10) And (Num < 16)) Then Select Case Num Case 11 : Write("ONCE") Case 12 : Write("DOCE") Case 13 : Write("TRECE") Case 14 : Write("CATORCE") Case 15 : Write("QUINCE") End Select Else Dec = Num \ 10 Uni = Num - (Dec * 10) Select Case Dec Case 1 : Decena = "DIEZ" Case 2 : Decena = "VEINTE" Case 3 : Decena = "TREINTA" Case 4 : Decena = "CUARENTA" Case 5 : Decena = "CINCUENTA" Case 6 : Decena = "SESENTA" Case 7 : Decena = "SETENTA" Case 8 : Decena = "OCHENTA" Case 9 : Decena = "NOVENTA" End Select If (Uni 0) Then Select Case Uni Case 1 : Unidad = "UNO" Case 2 : Unidad = "DOS" Case 3 : Unidad = "TRES" Case 4 : Unidad = "CUATRO" Case 5 : Unidad = "CINCO" Case 6 : Unidad = "SEIS" Case 7 : Unidad = "SIETE" Case 8 : Unidad = "OCHO" Case 9 : Unidad = "NUEVE" End Select If (Dec = 1) Then Decena = "DIECI" End If If (Dec = 2) Then Decena = "VENTI" End If If ((Dec > 2) And (Dec < 10)) Then Write(Decena & " Y " & Unidad) Else Write(Decena & Unidad) End If Else Write(Decena) End If End If Else Write("NÚMERO INCORRECTO") End If ReadLine() End SubEnd Module

Ingrese un número y muestra en letras - PSeInt.Site

Ingrese un número y muestra en letras - PSeInt.Site

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web. ¿EN QUE PROGRAMA QUIERES VER EL

programar

es

https://aprendeprogramando.es/static/images/programar-ingrese-un-numero-y-muestra-en-letras-pseint-749-0.jpg

2024-05-19

 

Ingrese un número y muestra en letras - PSeInt.Site
Ingrese un número y muestra en letras - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /seleccion/ingresar-numero-de-dos-cifras-mostrar-su-valor-en-letras/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente