DESCUENTO DE UN SUPERMERCADO - PSeInt.Site

 

 

 

DESARROLLAMOS TUS ALGORITMOS (+51) 988411115

20. En el Supermercado, un cliente debe presionar un botón, dependiendo del color de lámpara que se encienda, obtiene un descuento, que es un porcentaje del valor de su compra, según se muestra en la tabla.

Color = Descuento (%)

 

------------------------

Blanco = 100

Verde = 50

Negro = 40

Celeste = 5

Rojo = 0

Calcular el descuento y el pago final (valor compra menos descuento) que realizará un cliente.

1. Ingreso de datos. (Pulsar Tecla para continuar y la función AZAR para saber el color)

2. Calcular el importe del descuento.

3. Calcular el pago final.

4. Mostrar: el importe del descuento y el pago final.

¿EN QUE PROGRAMA QUIERES VER EL CÓDIGO? :

Curso de autocad, google colaboratory, curso de C, certificacion google, curso marketing digital, cisco python, páginas Web.

  Lenguaje C

  C++

  C#

  Python

  Java NetBeans

PSeInt - FLEXIBLE DESCARGA CÓDIGO

Proceso www_pseint_site Escribir "VALOR DE COMPRA : " Leer compra Escribir "Pulse una tecla para obtener el color" Esperar Tecla color = azar(5) Segun (color) Hacer 1: Escribir "COLOR : BLANCO" dsct = 1 2: Escribir "COLOR : VERDE" dsct = 0.5 3: Escribir "COLOR : NEGRO" dsct = 0.4 4: Escribir "COLOR : CELESTE" dsct = 0.05 5: Escribir "COLOR : ROJO" dsct = 0 FinSegun Escribir "DESCUENTO : ", dsct Escribir "IMPORTE DEL DESCUENTO : ", compra * dsct Escribir "PAGO FINAL : ", compra - (compra * dsct) FinProceso

PSeInt - ESTRICTO DESCARGA CÓDIGO

Proceso www_pseint_site Definir color como Entero; Definir dsct, compra como Real; dsct

DESCUENTO DE UN SUPERMERCADO - PSeInt.Site

DESCUENTO DE UN SUPERMERCADO - PSeInt.Site

------------------------ Color = Descuento (%) Color = Descuento (%) DESARROLLAMOS TUS ALGORITMOS (+51) 988411115 DESARROLLAMOS TUS ALGORITMOS (+51) 9884

programar

es

https://aprendeprogramando.es/static/images/programar-descuento-de-un-supermercado-pseint-657-0.jpg

2024-05-17

 

DESCUENTO DE UN SUPERMERCADO - PSeInt.Site
DESCUENTO DE UN SUPERMERCADO - PSeInt.Site

MÁS INFORMACIÓN

El contenido original se encuentra en /condicional/control-de-un-supermercado-pulsando-un-boton/
Todos los derechos reservados para el autor del contenido original (en el enlace de la linea superior)
Si crees que alguno de los contenidos (texto, imagenes o multimedia) en esta página infringe tus derechos relativos a propiedad intelectual, marcas registradas o cualquier otro de tus derechos, por favor ponte en contacto con nosotros en el mail [email protected] y retiraremos este contenido inmediatamente